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Introduction
The intent of this document is to provide an overview of how to utilize MnTOPO contour data as published in an open source shape (SHP) file
 format as a source for a digital terrain model (also known as a Triangulated Irregular Network or TIN) within a CAD environment and in a
 unit of measure consistent with most surveying projects. In this particular example, the discussion will be focused around Carlson Survey
 (version 2015) featuring the IntelliCAD engine with the goal of converting the data to U.S. Survey Feet and in a Minnesota County
 Coordinate System.

Per the Overview section found at http://files.dnr.state.mn.us/aboutdnr/gis/mntopo/mntopo_help_document.pdf (MnTOPO Help Document):

"MnTOPO is a web application for viewing, printing and downloading high-resolution elevation data for Minnesota that was collected using
 LiDAR technology. It runs on a variety of devices, including desktops, tablets, and mobile phones."

As with most data, it is important to know the positional "metadata" associated with the information we will be fetching. Knowing this
 information makes it possible to correctly georeference the data into a coordinate system of our choosing. From the Data Download section
 of the aforementioned MnTOPO Help Document, the data is published in the following coordinate system:

"UTM Zone 15, NAD83"

As with most data of this type, the units of the data are in Meters.

NOTE: Although the western portion of Minnesota falls with UTM Zone 14 and the extreme north-eastern portion of Minnesota falls within
 UTM Zone 16, the MnTOPO service generates all of its data in UTM Zone 15.

NOTE: Per the Qualifications section of the MnTOPO Help Document:

"Disclaimer: Data shown and provided is subject to the disclaimers provided in the data documentation. The data was collected in several
 different phases so accuracy and available products vary; please review metadata for individual LiDAR collection blocks.

MnTOPO is not meant to provide high accuracy profiles required by some applications."

Using MnTOPO
Although the proper use of the MnTOPO site is described verbosely in the MnTOPO Help Document, the following sections will provide a brief
 overview of how to use the MnTOPO site.

Locating the Desired Site
1. Access the MnTOPO site by visiting http://arcgis.dnr.state.mn.us/maps/mntopo/
2. Locate the desired region by using one or more of the following navigation tools:

Quick search (e.g. Shakespear Blvd, Lakeville, Dakota County):

Zoom In, Zoom Out, Zoom Extents:

GPS Position of a GPS- and web-enabled smart-phone or tablet:

http://arcgis.dnr.state.mn.us/maps/mntopo/
http://en.wikipedia.org/wiki/Shapefile
http://www.carlsonsw.com/solutions/land-survey/survey/
http://www.carlsonsw.com/support/intellicad/
http://en.wikipedia.org/wiki/Foot_%28unit%29#Survey_foot
http://www.dot.state.mn.us/surveying/toolstech/mapproj.html#83MnCCS
http://www.dot.state.mn.us/surveying/toolstech/mapproj.html#83MnCCS
http://files.dnr.state.mn.us/aboutdnr/gis/mntopo/mntopo_help_document.pdf
http://en.wikipedia.org/wiki/Metadata
http://en.wikipedia.org/wiki/Georeference
http://arcgis.dnr.state.mn.us/maps/mntopo/


NOTE: Once you have located your desired region, make a mental note of the contour elevations for later validation purposes.

Get the Desired Data
1. Initial the Download Data process via the following web control:

2. Upon launch of the Download Data process, an additional four steps are required:
1. Select (draw) an area of interest.
2. Select (specify) the desired product(s). For the purposes of this discussion, our focus will be on the Contours data type.

NOTE: Based on availability, various Carlson Software products can also make direct use of other MnTOPO data products:
DEM (digital elevation model) files can be imported in the Grid File Utilities command found in Carlson Civil.
LAS (Laser, also LAZ) and Bare Earth files can be imported via the Cloud → Import command found in Carlson Point Cloud.

3. Select a product type. For the purposes of this discussion, our focus will be on the Open Source data type.
4. Enter your Email address for where the data download URL can be sent.

Receiving the Data
Upon submittal and acceptance of the MnTOPO Terms of Service, the MnTOPO server will process the data products and send an Email with a
 web-link (or URL) to a zipped file of where the data can be downloaded. Using conventional means, download the ZIP and then extract its
 content to a designated folder on your computer. For the benefit of this overview, we will assume the data has been saved to a folder
 location given as C:\Carlson Projects\MnTOPO (but any folder will suffice). Within the ZIP file will likely be a shapefile comprised of the
 following files:

contours.dbf (required)
contours.shp (required)
contours.shx (required)
contours.prj (optional)

Make sure these files have been extracted from the ZIP file before continuing.

Using the Data in CAD
As described above, Carlson Survey will be used to describe the process that follows but other CAD-based products should also be capable of
 generating similar results (their procedures, however, will probably vary from those described below).

Start into an Empty Drawing
1. Launch into Carlson Survey via the Carlson icon installed to your Desktop. If you do not have Carlson Survey installed to your

 computer, a free 30-day evaluation version can be obtained at the Carlson Software Downloads page.
2. If the Start-up Wizard dialog box appears, click Exit to close it.

NOTE: At this point, you should have a GIS menu on the screen. If you do not, click Settings → Carlson Menus → Survey Menu. This will load
 the Carlson Survey menu group which contains the desired GIS menu.

Prepare for the Incoming Data
Before we bring in our MnTOPO data, we'll want to prepare our drawing to match the coordinate system zone information that is delivered
 with MnTOPO data and get it ready to accept the incoming data.

1. From the Settings menu, click Drawing Setup and set the values as shown below and click OK when complete:

http://www.carlsonsw.com/solutions/civil-engineering/civil/
http://www.carlsonsw.com/solutions/land-survey/point-cloud/
http://www.carlsonsw.com/support/software-downloads/


2. From the GIS menu, click GIS Database Settings to display the GIS Settings dialog box:

3. Click the Select button within the GIS Features group to display the Select GIS Features File dialog box. Set the values as shown below
 and click Open when complete:



4. Click the Select button within the Data Format group (see GIS Settings dialog box example above) to display the New or Existing File
 dialog box below:

5. Click on the New Access 2000 Format button to display the Database File to Write dialog box. Set the values as shown below and click
 Save when complete:

6. Confirm the completed GIS Settings as shown below and click Exit when complete:



We should now be ready to import our data.

NOTE: For additional GIS considerations, check out the Carlson GIS Primer.

Importing the Esri SHP File
1. From the GIS menu, click Import ESRI SHP File to display the Import SHP File dialog box. Set the values as illustrated below and click

 the Import Polylines from SHP button when complete:

2. From the View menu, click Extents (aka Zoom Extents) to see the data that has been brought into the drawing.
3. It is often helpful to make periodic "saves" to the drawing. From the File menu, click Save As and save the drawing as C:\Carlson

 Projects\MnTOPO\MnTOPO.dwg.

Limiting the Imported Data
The MnTOPO site typically sends more data than we originally specified. Let's remove the content we don't want in an effort to keep our
 processing obligations to a minimum.

1. From the Draw menu, click Rectangle. Pick two identifying corners of a rectangle that bounds the area you'd like to study.
2. From the Edit menu, click Erase → Erase by Closed Polyline. When prompted:

Select perimeter polyline: select the rectangular polyline you just drew.
3. The Select Entity Types to Clip dialog box appears. Set the values as shown below and click the OK button when complete:

http://www.carlsonsw.com/solutions/gis-products/gis-primer/


The end result should be the desired subset of the data that was provided to us.

NOTE: If desired, the rectangular polyline drawn previously can be discarded (use the Edit → Erase → Single command to erase the polyline
 boundary).

Transforming the Data
As mentioned earlier, our goal will be to utilize the data in a local Minnesota County Coordinate System. Now that we've limited our data,
 let's set it to our desired coordinate system and in U.S. Survey Feet.

1. Let's make sure all of our layers are On and Thawed. From the View menu, click Thaw/On All Layers.
2. From the Points menu, click Adjust Coordinates → Coordinate Transformation.

NOTE: You may be prompted to select a Coordinate File to Process. This is a benign requirement at this stage so accept the default
 coordinate file name and click Open to create or open a coordinate file.

The preliminary Coordinate Transformation dialog box appears. Set the values as shown below and click OK to continue:

3. The next Coordinate Transformation dialog box allows us to select the different coordinate systems that shall be used to complete the
 transformation. After selecting the More Pre-Defined/User-Defined option, we'll use the pair of Set buttons to define our Source and
 Destination systems:

4. Click on the Set button in the Source Coordinates group. The Select Projection dialog box appears:

a. Click on the Add Pre-Defined button to display the Select Projection dialog box. Set the values as shown below and click on the
 OK button when complete:



b. The Source coordinate system is added as one of our "favorites":

NOTE: At this point, you can use the Edit option to inspect and/or adjust the specific values associated with the selected
 coordinate system. Click on the OK button.

5. As we can see, we've successfully added the information for our Source coordinate system to the Coordinate Transformation dialog
 box:

6. Click on the Set button in the Destination Coordinates group. The Select Projection dialog box re-appears:

a. Click on the Add Pre-Defined button to display the Select Projection dialog box. Set the values as shown below and click on the
 OK button when complete:



b. The Destination coordinate system is added as one of our "favorites". Click on the OK button:

7. As we can see, we've successfully added the information for our Destination coordinate system to the Coordinate Transformation dialog
 box:

8. Click the OK button to dismiss the Coordinate Transformation dialog box and to initiate the computational algorithm. When prompted:
Select entities for coordinate transformation.

FILter/<Select entities>: type all and press the Enter key twice
NOTE: Depending on the computing power of your computer and the number of entities selected for the transformation, the process
 might take several minutes to complete. At the completion of the transformation, an alert message box will appear indicating the
 processing has completed.

9. From the View menu, click Extents (aka Zoom Extents) to see the data in its new position.

Revise the Drawing Setup and Validate
Now that we've successfully completed the transformation, let's utilize the new coordinate system as data check.

1. From the Settings menu, click Drawing Setup and set the values as shown below and click OK when complete:



2. For the work to follow, let's reduce the number of polyline vertices. From the Edit menu, click Polyline Utilities → Reduce Polyline
 Vertices. When prompted:
Offset cutoff <0.10000>: specify a value of 0.1 and press the Enter key

3. When prompted:
Select polylines to reduce.

FILter/<Select entities>: type all and press the Enter key twice

4. To validate the current position of our data, we'll utilize Google Earth. From the File menu, click Export → Google Earth File to display
 the Export to KML/KMZ dialog box. Set the values as shown below and click OK when complete:

5. When prompted, provide a filename of Contours as shown below:

http://www.google.com/earth/


6. When prompted:
Select points, polylines, text, solids, images, lines and arcs to write.

FILter/<Select entities>: type all and press the Enter key twice

Google Earth (if installed) should automatically launch and display the new and correct positions of the contours based on how they
 were transformed and the current projection information as established in Drawing Setup.

7. Dismiss the Google Earth application.
8. It is often helpful to make periodic "saves" to the drawing. From the File menu, click Save As and save the drawing as C:\Carlson

 Projects\MnTOPO\MnTOPO.dwg.

Now that we've validated our data, let's make a digital terrain model.

Creating a TIN
Now that we've successfully migrated our data to the desired coordinate system, our final task will be to utilize this data as the source for a
 triangulated, irregular network (TIN).

1. From the Surface menu, click Triangulate & Contour. Make sure the Triangulation tab is active and establish the various settings cited
 below (narrative explanation follows the screen capture below):



Write Triangulation File: Enable this toggle to physically generate a TIN file. Use the Browse button to create a TIN file name
 as shown below:

Shrink-Wrap Perimeter Reduction: Indicate a desired "heat" level for a software-generated boundary that will surround the
 data.
Interpolate Ridges and Valleys: The intent of this routine is similar to, and is the pre-cursor of the Minimize Flat Triangles
 option. When enabled, this option inserts "best-guess" breaklines into the drawing which are subsequently used in the
 triangulation process in an attempt to minimize flat, horizontal triangles.
Interpolate Summits and Pits: When enabled, this option creates additional triangulation in a summit or pit situation to more
 accurately represent existing ground conditions from a surface model created from contour entities. Since the tops of hills and
 the bottom of pits are often not shown on existing ground contour maps, this option often helps improve the accuracy of existing
 terrain conditions.
Minimize Flat Triangles: When enabled, this toggle instructs the triangulation "engine" to iterate through the triangulation
 permutations to minimize the occurrence of "flat" (or more precisely, horizontal) triangles. Flat triangles often occur when
 creating surface models from contour data.

2. Click on the Contour tab and set the value cited below (since our source data is contours, there is no need to draw them again):



NOTE: If the Contours functionality is disabled, the Labels functionality is also disabled.
3. Click on the Selection tab and set the values cited below:

4. Click on the OK button of the Triangulate and Contour dialog box. When prompted:
Select points and breaklines to Triangulate.

FILter/<Select entities>: type all and press the Enter key twice

A Carlson TIN is formed.

Viewing the TIN in 3D
Now that we've built the TIN, let's examine it in 3D.

1. From the View menu, click Surface 3D Viewer.
2. Select the TIN created earlier and click Open.
3. Use the various tools highlighted below to inspect your model:

4. Exit from the Surface 3D Viewer command when you have completed examining the model.

Conclusion
Through a careful but concise logic of generating, importing and converting MnTOPO data, it is possible to leverage this data within a CAD
 environment to produce a digital surface model in local Minnesota County-based coordinate systems and in U.S. Survey Feet.
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